summaryrefslogtreecommitdiff
path: root/src/qcam/meson.build
diff options
context:
space:
mode:
authorNiklas Söderlund <niklas.soderlund@ragnatech.se>2020-04-27 23:51:44 +0200
committerNiklas Söderlund <niklas.soderlund@ragnatech.se>2020-05-01 12:24:07 +0200
commitd29c32135709b18f430b75b8f9fc2592a5915149 (patch)
tree1262532a102f9e596afc6db40d1058740d3d6abd /src/qcam/meson.build
parent18cfea19dc593f47bf78f7abf108b0c6033ccf33 (diff)
qcam: Make use of StreamKeyValueParser
Use the StreamKeyValueParser helper to parse stream configuration from the command line. This extends qcam to accept role hints and pixel format in addition to a size. Currently only one viewfinder stream is supported, add a check to keep this behavior. Going forward this restriction will be lifted to support more then one stream. Signed-off-by: Niklas Söderlund <niklas.soderlund@ragnatech.se> Reviewed-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com>
Diffstat (limited to 'src/qcam/meson.build')
-rw-r--r--src/qcam/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/qcam/meson.build b/src/qcam/meson.build
index c256d06f..895264be 100644
--- a/src/qcam/meson.build
+++ b/src/qcam/meson.build
@@ -3,6 +3,7 @@ qcam_sources = files([
'main.cpp',
'main_window.cpp',
'../cam/options.cpp',
+ '../cam/stream_options.cpp',
'viewfinder.cpp',
])