summaryrefslogtreecommitdiff
path: root/src/qcam/meson.build
diff options
context:
space:
mode:
authorKieran Bingham <kieran.bingham@ideasonboard.com>2019-06-20 17:11:33 +0100
committerKieran Bingham <kieran.bingham@ideasonboard.com>2019-07-04 22:11:27 +0100
commit843e4466cd78b3369b1e77af0bf3b33cbd09129d (patch)
treed60f82cfaa145773aa2bcdc4f5a318f288d9a529 /src/qcam/meson.build
parent2976dd6a7e202d161077a454b28e9fcce98945c1 (diff)
qcam: Update window title with FPS
Provide an average FPS in the QCam title bar to show the current rate of frame processing. The QCam compilation is updated to process the Qt MoC headers to support signals and slots accordingly. Reviewed-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> Signed-off-by: Kieran Bingham <kieran.bingham@ideasonboard.com>
Diffstat (limited to 'src/qcam/meson.build')
-rw-r--r--src/qcam/meson.build11
1 files changed, 9 insertions, 2 deletions
diff --git a/src/qcam/meson.build b/src/qcam/meson.build
index 9f1fa75f..21f91f25 100644
--- a/src/qcam/meson.build
+++ b/src/qcam/meson.build
@@ -7,14 +7,21 @@ qcam_sources = files([
'viewfinder.cpp',
])
-import('qt5')
+qcam_moc_headers = files([
+ 'main_window.h',
+])
+
+qt5 = import('qt5')
qt5_dep = dependency('qt5',
method : 'pkg-config',
modules : ['Core', 'Gui', 'Widgets'],
required : false)
if qt5_dep.found()
- qcam = executable('qcam', qcam_sources,
+ moc_files = qt5.preprocess(moc_headers: qcam_moc_headers,
+ dependencies: qt5_dep)
+
+ qcam = executable('qcam', qcam_sources, moc_files,
install : true,
dependencies : [libcamera_dep, qt5_dep],
cpp_args : '-DQT_NO_KEYWORDS')