summaryrefslogtreecommitdiff
path: root/src/qcam/meson.build
diff options
context:
space:
mode:
authorKieran Bingham <kieran.bingham@ideasonboard.com>2020-02-05 14:41:14 +0000
committerKieran Bingham <kieran.bingham@ideasonboard.com>2020-02-14 12:34:33 +0000
commit2dc85eabe1d9e9946f39692ea9a3bf1bb635bbcc (patch)
treebafc799250835bd3e417cd60cdaf55b0c214be04 /src/qcam/meson.build
parentfc9fe45580839cee9420415f6d04052f9dfcaa62 (diff)
qcam: Provide initial icon buttons "Play/Stop"
Provide Quit, Play, Stop icons. Create a Qt resource to compile icons into the binary and present them on the toolbar. Update the Quit button with a 'cross', and implement Play/Stop buttons. Signed-off-by: Kieran Bingham <kieran.bingham@ideasonboard.com> Reviewed-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com>
Diffstat (limited to 'src/qcam/meson.build')
-rw-r--r--src/qcam/meson.build9
1 files changed, 7 insertions, 2 deletions
diff --git a/src/qcam/meson.build b/src/qcam/meson.build
index 1e71f20f..5b877a84 100644
--- a/src/qcam/meson.build
+++ b/src/qcam/meson.build
@@ -11,6 +11,10 @@ qcam_moc_headers = files([
'main_window.h',
])
+qcam_resources = files([
+ 'assets/feathericons/feathericons.qrc',
+])
+
qt5 = import('qt5')
qt5_dep = dependency('qt5',
method : 'pkg-config',
@@ -30,10 +34,11 @@ if qt5_dep.found()
endif
endif
- moc_files = qt5.preprocess(moc_headers: qcam_moc_headers,
+ resources = qt5.preprocess(moc_headers: qcam_moc_headers,
+ qresources : qcam_resources,
dependencies: qt5_dep)
- qcam = executable('qcam', qcam_sources, moc_files,
+ qcam = executable('qcam', qcam_sources, resources,
install : true,
dependencies : [libcamera_dep, qt5_dep],
cpp_args : qt5_cpp_args)