summaryrefslogtreecommitdiff
path: root/src/qcam/meson.build
diff options
context:
space:
mode:
authorLaurent Pinchart <laurent.pinchart@ideasonboard.com>2020-03-22 00:52:28 +0200
committerLaurent Pinchart <laurent.pinchart@ideasonboard.com>2020-03-24 10:33:40 +0200
commit01590c3f780598572b3a18decefed55ae8e51059 (patch)
tree45528bc03285507b3c4d6129dc9162cef4bc6b5e /src/qcam/meson.build
parent45f248da7dbd0dc6df02142bfdf99a5d7f5f80a2 (diff)
qcam: Remove custom event dispatcher
The qcam application installs a custom event dispatcher based on the Qt event loop. As the camera manager now creates an internal thread, it doesn't use that event dispatcher of the application thread at all. Furthermore, the custom event dispatcher is buggy, as it doesn't dispatch messages posted to the main thread's event loop. This isn't an issue as no messages are posted there in the first place, but would cause incorrect behaviour if we were to use that feature (for instance to deliver signals from the camera manager thread to the application thread). Fixing the event dispatcher requires a change in the libcamera public API, as there's currently no way to dispatch messages using the public API (Thread::dispatchMessages() is not exposed). This isn't worth it at the moment, so just remove the custom event dispatcher. If qcam later needs the libcamera request and buffer completion signals to be delivered in the application thread, it will need to handle that internally, using Qt's cross-thread signal delivery. Signed-off-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> Reviewed-by: Kieran Bingham <kieran.bingham@ideasonboard.com>
Diffstat (limited to 'src/qcam/meson.build')
-rw-r--r--src/qcam/meson.build1
1 files changed, 0 insertions, 1 deletions
diff --git a/src/qcam/meson.build b/src/qcam/meson.build
index 5150631b..214bfb12 100644
--- a/src/qcam/meson.build
+++ b/src/qcam/meson.build
@@ -3,7 +3,6 @@ qcam_sources = files([
'main.cpp',
'main_window.cpp',
'../cam/options.cpp',
- 'qt_event_dispatcher.cpp',
'viewfinder.cpp',
])