summaryrefslogtreecommitdiff
path: root/src/py/libcamera/meson.build
diff options
context:
space:
mode:
authorTomi Valkeinen <tomi.valkeinen@ideasonboard.com>2022-05-27 17:44:33 +0300
committerLaurent Pinchart <laurent.pinchart@ideasonboard.com>2022-05-27 22:03:46 +0300
commite115a691353151b3136581ac7f49cab6a3b0eb9a (patch)
tree6360bcaa85cc9f4dee06731c09ce2cec96fc37a3 /src/py/libcamera/meson.build
parenta69b73cc584e276e967c484a2592b0f47663b541 (diff)
py: Use ln --relative to create symlinks
We create symlinks from the Python bindings build dir to the source dir so that 1) the build dir can be used to use the bindings, and 2) to allow modifications of the source .py files to be used right away without rebuilding. The symlinks were recently fixed and changed to use absolute paths. However, absolute paths ruin one main use case I have: using the bindings from the build dir via nfs from an ARM device. So move back to relative paths, but accomplish this with the --relative parameter for ln, instead of guessing the right relative path as was done before the above-mentioned fix. Signed-off-by: Tomi Valkeinen <tomi.valkeinen@ideasonboard.com> Reviewed-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> Signed-off-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com>
Diffstat (limited to 'src/py/libcamera/meson.build')
-rw-r--r--src/py/libcamera/meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/py/libcamera/meson.build b/src/py/libcamera/meson.build
index afa7efed..eb884538 100644
--- a/src/py/libcamera/meson.build
+++ b/src/py/libcamera/meson.build
@@ -84,11 +84,11 @@ pycamera = shared_module('_libcamera',
# Create symlinks from the build dir to the source dir so that we can use the
# Python module directly from the build dir.
-run_command('ln', '-fsT', files('__init__.py'),
+run_command('ln', '-fsrT', files('__init__.py'),
meson.current_build_dir() / '__init__.py',
check: true)
-run_command('ln', '-fsT', meson.current_source_dir() / 'utils',
+run_command('ln', '-fsrT', meson.current_source_dir() / 'utils',
meson.current_build_dir() / 'utils',
check: true)