summaryrefslogtreecommitdiff
path: root/src/py/libcamera/meson.build
diff options
context:
space:
mode:
authorTomi Valkeinen <tomi.valkeinen@ideasonboard.com>2022-05-18 16:13:26 +0300
committerLaurent Pinchart <laurent.pinchart@ideasonboard.com>2022-05-18 17:52:31 +0300
commitb2ada6f3ec64dc97e7facdc32d99fbe7b76e0982 (patch)
tree7b037b37c7244de4a3e5c19041a30ef8dd2fa1f4 /src/py/libcamera/meson.build
parent2bb6c9fbd2e2dac0b266b6762401db142fe47475 (diff)
py: Rename pyxyz to py_xyz
Having the underscore makes the names more readable, especially when there are multiple words in the name. Signed-off-by: Tomi Valkeinen <tomi.valkeinen@ideasonboard.com> Reviewed-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> Reviewed-by: Kieran Bingham <kieran.bingham@ideasonboard.com> Signed-off-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com>
Diffstat (limited to 'src/py/libcamera/meson.build')
-rw-r--r--src/py/libcamera/meson.build10
1 files changed, 5 insertions, 5 deletions
diff --git a/src/py/libcamera/meson.build b/src/py/libcamera/meson.build
index de66bb48..55957252 100644
--- a/src/py/libcamera/meson.build
+++ b/src/py/libcamera/meson.build
@@ -13,21 +13,21 @@ pybind11_proj = subproject('pybind11')
pybind11_dep = pybind11_proj.get_variable('pybind11_dep')
pycamera_sources = files([
- 'pyenums.cpp',
- 'pygeometry.cpp',
- 'pymain.cpp',
+ 'py_enums.cpp',
+ 'py_geometry.cpp',
+ 'py_main.cpp',
])
gen_input_files = files([
'../../libcamera/control_ids.yaml',
- 'pyenums_generated.cpp.in',
+ 'py_enums_generated.cpp.in',
])
gen_py_control_enums = files('gen-py-control-enums.py')
generated_sources = custom_target('py_gen_controls',
input : gen_input_files,
- output : ['pyenums_generated.cpp'],
+ output : ['py_enums_generated.cpp'],
command : [gen_py_control_enums, '-o', '@OUTPUT@', '@INPUT@'])
pycamera_sources += generated_sources