summaryrefslogtreecommitdiff
path: root/src/meson.build
diff options
context:
space:
mode:
authorLaurent Pinchart <laurent.pinchart@ideasonboard.com>2020-09-16 16:04:03 +0300
committerLaurent Pinchart <laurent.pinchart@ideasonboard.com>2020-09-16 18:15:28 +0300
commitd5ce2679c67877295ce0096afd3d24d28ad34d16 (patch)
tree460048faef4fd8b869edfaf60845b554a42cf588 /src/meson.build
parentde20029a582a71a87d99388a62fb63c86e85028a (diff)
libcamera: Turn the android option into a feature
Allow disabling compilation of the Android HAL adaptation layer automatically when a dependency is missing by turning the android option into a feature. The default value is set to 'disabled' to match the current behaviour. Signed-off-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> Reviewed-by: Kieran Bingham <kieran.bingham@ideasonboard.com> Reviewed-by: Niklas Söderlund <niklas.soderlund@ragnatech.se>
Diffstat (limited to 'src/meson.build')
-rw-r--r--src/meson.build4
1 files changed, 1 insertions, 3 deletions
diff --git a/src/meson.build b/src/meson.build
index d69b4c1e..0c5b64d6 100644
--- a/src/meson.build
+++ b/src/meson.build
@@ -1,8 +1,6 @@
# SPDX-License-Identifier: CC0-1.0
-if get_option('android')
- subdir('android')
-endif
+subdir('android')
openssl = find_program('openssl', required : true)
if openssl.found()