summaryrefslogtreecommitdiff
path: root/src/meson.build
diff options
context:
space:
mode:
authorLaurent Pinchart <laurent.pinchart@ideasonboard.com>2020-04-16 14:49:24 +0300
committerLaurent Pinchart <laurent.pinchart@ideasonboard.com>2020-04-16 17:37:41 +0300
commitb382f67c833de08717cfec19273b95f5819cab27 (patch)
tree938585d23a2b15237c385f48e7ffaee02fe68cac /src/meson.build
parent06260fdfd6420a6324e20dc11726d6d69747646a (diff)
libcamera: Make IPA module signing mandatory for the meantime
IPA module signing is optional, but when not available due to missing dependencies, we hit failures due to a non fully implemented IPA isolation. Make module signing mandatory until isolation is functional. Signed-off-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> Reviewed-by: Kieran Bingham <kieran.bingham@ideasonboard.com>
Diffstat (limited to 'src/meson.build')
-rw-r--r--src/meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/meson.build b/src/meson.build
index 29668275..f605a420 100644
--- a/src/meson.build
+++ b/src/meson.build
@@ -2,7 +2,7 @@ if get_option('android')
subdir('android')
endif
-openssl = find_program('openssl', required : false)
+openssl = find_program('openssl', required : true)
if openssl.found()
ipa_gen_priv_key = find_program('ipa/gen-ipa-priv-key.sh')
ipa_priv_key = custom_target('ipa-priv-key',