summaryrefslogtreecommitdiff
path: root/src/meson.build
diff options
context:
space:
mode:
authorJacopo Mondi <jacopo@jmondi.org>2019-05-10 17:40:02 +0200
committerJacopo Mondi <jacopo@jmondi.org>2019-08-12 11:55:46 +0200
commit667d8ea8fd4bda35e8888792d2b6c055fdb4be18 (patch)
tree786462c9f8dfce3d3d05d69dc8befcd67e94db07 /src/meson.build
parent6bed34da161bb8c4e86821116dcff2205e29c58a (diff)
android: hal: Add Camera3 HAL
Add libcamera Android Camera HALv3 implementation. The initial camera HAL implementation supports the LIMITED hardware level and uses statically defined metadata and camera characteristics. Add a build option named 'android' and adjust the build system to selectively compile the Android camera HAL and link it against the required Android libraries. Signed-off-by: Jacopo Mondi <jacopo@jmondi.org>
Diffstat (limited to 'src/meson.build')
-rw-r--r--src/meson.build5
1 files changed, 4 insertions, 1 deletions
diff --git a/src/meson.build b/src/meson.build
index 7148baee..67ad20aa 100644
--- a/src/meson.build
+++ b/src/meson.build
@@ -1,4 +1,7 @@
-subdir('android')
+if get_option('android')
+ subdir('android')
+endif
+
subdir('libcamera')
subdir('ipa')
subdir('cam')