summaryrefslogtreecommitdiff
path: root/src/meson.build
diff options
context:
space:
mode:
authorKieran Bingham <kieran.bingham@ideasonboard.com>2021-04-15 15:52:10 +0200
committerKieran Bingham <kieran.bingham@ideasonboard.com>2021-04-30 11:53:09 +0100
commit3a1f67a8031ac5ad96a11d5dc8b2e8976290497b (patch)
tree6411713f22d2238d546eef653aac95df9103ce70 /src/meson.build
parent7065ad84f00537046ff15555bb60de6a7db274aa (diff)
src: meson: Define system paths
Define libcamera specific system paths for use within the library code base. These can be used to identify system configuration files and shared data. Also, make use of the new system path variables and map the ipa paths upon the libcamera system path, making use of the new shorter syntax for join_paths(). Reviewed-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> Signed-off-by: Jacopo Mondi <jacopo@jmondi.org> Signed-off-by: Kieran Bingham <kieran.bingham@ideasonboard.com>
Diffstat (limited to 'src/meson.build')
-rw-r--r--src/meson.build9
1 files changed, 9 insertions, 0 deletions
diff --git a/src/meson.build b/src/meson.build
index 29ad2d33..edb7ce14 100644
--- a/src/meson.build
+++ b/src/meson.build
@@ -1,5 +1,14 @@
# SPDX-License-Identifier: CC0-1.0
+# Cache system paths
+libcamera_datadir = get_option('datadir') / 'libcamera'
+libcamera_libdir = get_option('libdir') / 'libcamera'
+libcamera_sysconfdir = get_option('sysconfdir') / 'libcamera'
+
+config_h.set('LIBCAMERA_DATA_DIR', '"' + get_option('prefix') / libcamera_datadir + '"')
+config_h.set('LIBCAMERA_SYSCONF_DIR', '"' + get_option('prefix') / libcamera_sysconfdir + '"')
+
+# Module Signing
openssl = find_program('openssl', required : true)
if openssl.found()
ipa_priv_key = custom_target('ipa-priv-key',