summaryrefslogtreecommitdiff
path: root/src/meson.build
diff options
context:
space:
mode:
authorPaul Elder <paul.elder@ideasonboard.com>2019-12-06 04:14:52 -0500
committerPaul Elder <paul.elder@ideasonboard.com>2020-01-03 19:53:20 -0500
commit0ce8f2390b5280887a2ac179faf2aa01604cb1cc (patch)
treeea8d04e9013b87217bd8266eab5356c03ded19fa /src/meson.build
parenta3b80f3af87198b97f11f0694ff4d7ddde63fc30 (diff)
v4l2: v4l2_compat: Add V4L2 compatibility layer
Add libcamera V4L2 compatibility layer. This initial implementation supports the minimal set of V4L2 operations, which allows getting, setting, and enumerating formats, and streaming frames from a video device. Some data about the wrapped V4L2 video device are hardcoded. Add a build option named 'v4l2' and adjust the build system to selectively compile the V4L2 compatibility layer. For now we match the V4L2 device node to a libcamera camera based on a devnum that a pipeline handler may optionally map to a libcamera camera. Signed-off-by: Paul Elder <paul.elder@ideasonboard.com> Reviewed-by: Jacopo Mondi <jacopo@jmondi.org> Reviewed-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com>
Diffstat (limited to 'src/meson.build')
-rw-r--r--src/meson.build4
1 files changed, 4 insertions, 0 deletions
diff --git a/src/meson.build b/src/meson.build
index 67ad20aa..5adcd61f 100644
--- a/src/meson.build
+++ b/src/meson.build
@@ -6,3 +6,7 @@ subdir('libcamera')
subdir('ipa')
subdir('cam')
subdir('qcam')
+
+if get_option('v4l2')
+ subdir('v4l2')
+endif