summaryrefslogtreecommitdiff
path: root/src/meson.build
diff options
context:
space:
mode:
authorPaul Elder <paul.elder@ideasonboard.com>2021-02-25 19:38:26 +0900
committerPaul Elder <paul.elder@ideasonboard.com>2021-03-03 19:05:12 +0900
commit09b0801fdb1716c809b1b442015a237974bf6fc5 (patch)
tree39a55d4fbdd3dc3258b62ae90a6310ce227fccd3 /src/meson.build
parentd8d6a78f223e14e3da7adf73ee54730ba0f1740b (diff)
cros: Support the new cros camera API with set_up and tear_down
Implement and expose the symbol and functions that the new cros camera API requires. Since we don't actually need them, leave them empty. Update meson accordingly. Signed-off-by: Paul Elder <paul.elder@ideasonboard.com> Reviewed-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> Reviewed-by: Jacopo Mondi <jacopo@jmondi.org>
Diffstat (limited to 'src/meson.build')
-rw-r--r--src/meson.build2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/meson.build b/src/meson.build
index 0b26ca70..c908b067 100644
--- a/src/meson.build
+++ b/src/meson.build
@@ -11,6 +11,8 @@ else
ipa_sign_module = false
endif
+libcamera_objects = []
+
# The 'android' subdir must be processed first, and the build targets
# are included directly into the libcamera library when this is enabled.
subdir('android')