summaryrefslogtreecommitdiff
path: root/src/meson.build
diff options
context:
space:
mode:
authorLaurent Pinchart <laurent.pinchart@ideasonboard.com>2020-05-11 00:23:41 +0300
committerLaurent Pinchart <laurent.pinchart@ideasonboard.com>2020-05-11 20:01:30 +0300
commit019a145068b714482bbf791c0f296abd06ec0dc1 (patch)
treec5f42aaffe01fedfa4c94164515f5f2bb361fa8c /src/meson.build
parentcfc9e148746e0629111e068447ce509cf8eb4b28 (diff)
meson: Use files() instead of find_program() for internal scripts
Using find_program() to locate scripts part of the source tree causes meson to print messages at setup time for each of those scripts: Program ipa-sign.sh found: YES (/home/user/src/libcamera/src/ipa/ipa-sign.sh) This pollutes the meson setup log with useless messages, as we know the scripts are present. Use files() instead to avoid this. Signed-off-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> Reviewed-by: Kieran Bingham <kieran.bingham@ideasonboard.com>
Diffstat (limited to 'src/meson.build')
-rw-r--r--src/meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/meson.build b/src/meson.build
index f605a420..c9c10085 100644
--- a/src/meson.build
+++ b/src/meson.build
@@ -4,7 +4,7 @@ endif
openssl = find_program('openssl', required : true)
if openssl.found()
- ipa_gen_priv_key = find_program('ipa/gen-ipa-priv-key.sh')
+ ipa_gen_priv_key = files('ipa/gen-ipa-priv-key.sh')
ipa_priv_key = custom_target('ipa-priv-key',
output : [ 'ipa-priv-key.pem' ],
command : [ ipa_gen_priv_key, '@OUTPUT@' ])