summaryrefslogtreecommitdiff
path: root/src/libcamera/pipeline/raspberrypi/meson.build
diff options
context:
space:
mode:
authorNaushir Patuck <naush@raspberrypi.com>2020-09-18 10:42:22 +0100
committerNiklas Söderlund <niklas.soderlund@ragnatech.se>2020-09-21 13:10:48 +0200
commit6bca768a0b632849493e00060177c56cd51bbf78 (patch)
tree6824c2a0d5beb4ad5d370c064940e260038cc6d4 /src/libcamera/pipeline/raspberrypi/meson.build
parente390f9f618ec694e5327ebe93cdfc0ba89ab5a86 (diff)
libcamera: pipeline: raspberrypi: Move RPiStream into a separate file
Put RPiStream into the RPi namespace and add a new log category (RPISTREAM). Reorder methods into logical groups for readability. There are no functional changes in this commit. Signed-off-by: Naushir Patuck <naush@raspberrypi.com> Reviewed-by: Niklas Söderlund <niklas.soderlund@ragnatech.se> Reviewed-by: Kieran Bingham <kieran.bingham@ideasonboard.com> Reviewed-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> Tested-by: David Plowman <david.plowman@raspberrypi.com> Signed-off-by: Niklas Söderlund <niklas.soderlund@ragnatech.se>
Diffstat (limited to 'src/libcamera/pipeline/raspberrypi/meson.build')
-rw-r--r--src/libcamera/pipeline/raspberrypi/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/libcamera/pipeline/raspberrypi/meson.build b/src/libcamera/pipeline/raspberrypi/meson.build
index ae0aed3b..7c5b6ff7 100644
--- a/src/libcamera/pipeline/raspberrypi/meson.build
+++ b/src/libcamera/pipeline/raspberrypi/meson.build
@@ -3,5 +3,6 @@
libcamera_sources += files([
'dma_heaps.cpp',
'raspberrypi.cpp',
+ 'rpi_stream.cpp',
'staggered_ctrl.cpp',
])