summaryrefslogtreecommitdiff
path: root/src/libcamera/pipeline/raspberrypi/meson.build
diff options
context:
space:
mode:
authorLaurent Pinchart <laurent.pinchart@ideasonboard.com>2020-05-12 03:18:02 +0300
committerLaurent Pinchart <laurent.pinchart@ideasonboard.com>2020-05-15 12:08:38 +0300
commit4d536996c7cab21ea5f29730001c4d1cc4b2e03f (patch)
tree3d382e36774666746078571abf88eb74cf9b6906 /src/libcamera/pipeline/raspberrypi/meson.build
parent924778eb073c47a0defc7319e98029c712129ede (diff)
libcamera: pipeline: raspberrypi: Don't inline all of StaggeredCtrl
The StaggeredCtrl class has large functions, move them to a .cpp file instead of inlining them all to reduce the binary size. Signed-off-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> Reviewed-by: Naushir Patuck <naush@raspberrypi.com>
Diffstat (limited to 'src/libcamera/pipeline/raspberrypi/meson.build')
-rw-r--r--src/libcamera/pipeline/raspberrypi/meson.build3
1 files changed, 2 insertions, 1 deletions
diff --git a/src/libcamera/pipeline/raspberrypi/meson.build b/src/libcamera/pipeline/raspberrypi/meson.build
index fc117b77..dcfe07c5 100644
--- a/src/libcamera/pipeline/raspberrypi/meson.build
+++ b/src/libcamera/pipeline/raspberrypi/meson.build
@@ -1,5 +1,6 @@
# SPDX-License-Identifier: CC0-1.0
libcamera_sources += files([
- 'raspberrypi.cpp'
+ 'raspberrypi.cpp',
+ 'staggered_ctrl.cpp',
])