summaryrefslogtreecommitdiff
path: root/src/libcamera/pipeline/meson.build
diff options
context:
space:
mode:
authorJacopo Mondi <jacopo@jmondi.org>2019-01-11 17:39:55 +0100
committerJacopo Mondi <jacopo@jmondi.org>2019-01-22 11:16:28 +0100
commit93734d7fe0d90296a9e7715ae12cbf1579fd7dd5 (patch)
treed00009af86897a6995bf821f45083f88a37ded5b /src/libcamera/pipeline/meson.build
parent8b8ae521347f293380f471285193aebbb3279f7d (diff)
libcamera: pipeline: Add Intel IPU3 pipeline
Add a pipeline handler for the Intel IPU3 device. The pipeline handler creates a Camera for each image sensor it finds to be connected to an IPU3 CSI-2 receiver, and enables the link between the two. Tested on Soraka, listing detected cameras on the system, verifying the pipeline handler gets matched and links properly enabled. Reviewed-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> Signed-off-by: Jacopo Mondi <jacopo@jmondi.org>
Diffstat (limited to 'src/libcamera/pipeline/meson.build')
-rw-r--r--src/libcamera/pipeline/meson.build2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/libcamera/pipeline/meson.build b/src/libcamera/pipeline/meson.build
index 615ecd20..811c075b 100644
--- a/src/libcamera/pipeline/meson.build
+++ b/src/libcamera/pipeline/meson.build
@@ -1,3 +1,5 @@
libcamera_sources += files([
'vimc.cpp',
])
+
+subdir('ipu3')