summaryrefslogtreecommitdiff
path: root/src/libcamera/pipeline/ipu3/meson.build
diff options
context:
space:
mode:
authorNiklas Söderlund <niklas.soderlund@ragnatech.se>2020-11-02 23:46:44 +0100
committerNiklas Söderlund <niklas.soderlund@ragnatech.se>2021-02-05 01:20:32 +0100
commitd2bc3eb7b69a2ae7e2e4bd69950247141668666c (patch)
tree2d970a67e6ae2315559171935d2c1b66238fa92e /src/libcamera/pipeline/ipu3/meson.build
parent82549ae253302bf612978282ea3858821465e8ed (diff)
libcamera: ipu3: Add helper for parameter and statistic buffers
Add a helper class to aid in associating a parameter and statistic buffer with each request queued to the pipeline. The helper helps with tracking the state of the extra buffers and in completing the request once all extra processing is done. This change only adds the helper more work is needed to integrate it with the pipeline and an IPA. Signed-off-by: Niklas Söderlund <niklas.soderlund@ragnatech.se> Reviewed-by: Jacopo Mondi <jacopo@jmondi.org> Reviewed-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com>
Diffstat (limited to 'src/libcamera/pipeline/ipu3/meson.build')
-rw-r--r--src/libcamera/pipeline/ipu3/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/libcamera/pipeline/ipu3/meson.build b/src/libcamera/pipeline/ipu3/meson.build
index d60e07ae..a1b0b31a 100644
--- a/src/libcamera/pipeline/ipu3/meson.build
+++ b/src/libcamera/pipeline/ipu3/meson.build
@@ -2,6 +2,7 @@
libcamera_sources += files([
'cio2.cpp',
+ 'frames.cpp',
'imgu.cpp',
'ipu3.cpp',
])