summaryrefslogtreecommitdiff
path: root/src/libcamera/meson.build
diff options
context:
space:
mode:
authorKieran Bingham <kieran.bingham@ideasonboard.com>2021-06-23 23:18:23 +0100
committerKieran Bingham <kieran.bingham@ideasonboard.com>2021-06-25 16:11:11 +0100
commitff7832d2cd9beb586987fb9619d0e734771583b6 (patch)
treee5d6167941972d36c542dc3bc980dae3ace67949 /src/libcamera/meson.build
parente228c290c956ac7823fb9347be8ea957cf6d6172 (diff)
libcamera: Move generated headers to private dep
The libcamera_generated_ipa_headers are only a dependency to internal components, and should not form part of the public API. Now that we have a private dependency, move the generated headers there. Reviewed-by: Paul Elder <paul.elder@ideasonboard.com> Reviewed-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> Signed-off-by: Kieran Bingham <kieran.bingham@ideasonboard.com>
Diffstat (limited to 'src/libcamera/meson.build')
-rw-r--r--src/libcamera/meson.build12
1 files changed, 4 insertions, 8 deletions
diff --git a/src/libcamera/meson.build b/src/libcamera/meson.build
index ebd37e06..d6905576 100644
--- a/src/libcamera/meson.build
+++ b/src/libcamera/meson.build
@@ -132,23 +132,19 @@ libcamera = shared_library('libcamera',
build_rpath : '/',
dependencies : libcamera_deps)
-# TODO Drop libcamera_generated_ipa_headers from libcamera_dep as libcamera_dep
-# is supposed to model the dependencies required for usage of the public API,
-# not the internal API. It is needed as as some external components such as the
-# unit tests make use of the generated headers and this creates a race in the
-# build.
-
libcamera_dep = declare_dependency(sources : [
libcamera_ipa_headers,
libcamera_public_headers,
- libcamera_generated_ipa_headers,
],
include_directories : libcamera_includes,
dependencies : libcamera_base,
link_with : libcamera)
# Internal dependency for components and plugins which can use private APIs
-libcamera_private = declare_dependency(dependencies : [
+libcamera_private = declare_dependency(sources : [
+ libcamera_generated_ipa_headers,
+ ],
+ dependencies : [
libcamera_dep,
libcamera_base_private,
])