summaryrefslogtreecommitdiff
path: root/src/libcamera/meson.build
diff options
context:
space:
mode:
authorJacopo Mondi <jacopo@jmondi.org>2018-12-20 15:20:37 +0100
committerJacopo Mondi <jacopo@jmondi.org>2018-12-31 18:56:41 +0100
commitf0e16f0389eefef14cccf232ec79f3a296a959da (patch)
tree5c9d198be4cf8caed9801e080a85009d97c2c52d /src/libcamera/meson.build
parent20d15d9dc47fcfbf1f02689cc4c882115abe507f (diff)
libcamera: Add MediaObject class hierarchy
Add a class hierarcy to represent all media objects a media graph represents. Add a base MediaObject class, which retains the global unique object id, and define the derived MediaEntity, MediaLink and MediaPad classes. This hierarchy will be used by the MediaDevice objects which represents and handles the media graph. Signed-off-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> Signed-off-by: Jacopo Mondi <jacopo@jmondi.org>
Diffstat (limited to 'src/libcamera/meson.build')
-rw-r--r--src/libcamera/meson.build2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/libcamera/meson.build b/src/libcamera/meson.build
index ac5bba05..2985d40c 100644
--- a/src/libcamera/meson.build
+++ b/src/libcamera/meson.build
@@ -4,12 +4,14 @@ libcamera_sources = files([
'device_enumerator.cpp',
'log.cpp',
'main.cpp',
+ 'media_object.cpp',
'pipeline_handler.cpp',
])
libcamera_headers = files([
'include/device_enumerator.h',
'include/log.h',
+ 'include/media_object.h',
'include/pipeline_handler.h',
'include/utils.h',
])