summaryrefslogtreecommitdiff
path: root/src/libcamera/meson.build
diff options
context:
space:
mode:
authorLaurent Pinchart <laurent.pinchart@ideasonboard.com>2018-12-04 23:52:34 +0200
committerLaurent Pinchart <laurent.pinchart@ideasonboard.com>2018-12-06 16:43:04 +0200
commitedbd2059d8a4bd759302ada4368fa4055638fd7f (patch)
tree13736c5f0d888b60fbfe6f6a94d420a5bd26b81c /src/libcamera/meson.build
parent913b3ee817a34bd78d5a8dc4fc9025920202db09 (diff)
libcamera: Add initial logger
The logger is based on the ostream API, allowing code to log messages in a native way. It automatically logs the time stamp, severity level, file name and line number. Many important features are missing, such as logging to file, logging classes, and log filtering based on the severity level, file name and class. Signed-off-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> Acked-by: Kieran Bingham <kieran.bingham@ideasonboard.com>
Diffstat (limited to 'src/libcamera/meson.build')
-rw-r--r--src/libcamera/meson.build5
1 files changed, 4 insertions, 1 deletions
diff --git a/src/libcamera/meson.build b/src/libcamera/meson.build
index 07d9cd44..fe38f8b2 100644
--- a/src/libcamera/meson.build
+++ b/src/libcamera/meson.build
@@ -1,4 +1,7 @@
-sources = ['main.cpp']
+sources = files([
+ 'log.cpp',
+ 'main.cpp',
+])
includes = [
libcamera_includes,