summaryrefslogtreecommitdiff
path: root/src/libcamera/meson.build
diff options
context:
space:
mode:
authorDavid Plowman <david.plowman@raspberrypi.com>2021-12-10 14:44:17 +0000
committerLaurent Pinchart <laurent.pinchart@ideasonboard.com>2021-12-13 11:29:01 +0200
commitddb5e9d37e05ec85da26aaf8be0442a5ca34280b (patch)
treed774911133f9aaf8038fbf7d9a7f2aba96f929ba /src/libcamera/meson.build
parent015fa7f718156f59d233b48653211d08f5567760 (diff)
libcamera: Add ColorSpace class
This class represents a color space by defining its color primaries, the transfer (gamma) function it uses, the YCbCr encoding and whether the output is full or limited range. Signed-off-by: David Plowman <david.plowman@raspberrypi.com> Reviewed-by: Naushir Patuck <naush@raspberrypi.com> Reviewed-by: Umang Jain <umang.jain@ideasonboard.com> Reviewed-by: Jacopo Mondi <jacopo@jmondi.org> Reviewed-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> Signed-off-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com>
Diffstat (limited to 'src/libcamera/meson.build')
-rw-r--r--src/libcamera/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/libcamera/meson.build b/src/libcamera/meson.build
index dc1cc52a..7ae909d4 100644
--- a/src/libcamera/meson.build
+++ b/src/libcamera/meson.build
@@ -9,6 +9,7 @@ libcamera_sources = files([
'camera_manager.cpp',
'camera_sensor.cpp',
'camera_sensor_properties.cpp',
+ 'color_space.cpp',
'controls.cpp',
'control_serializer.cpp',
'control_validator.cpp',