summaryrefslogtreecommitdiff
path: root/src/libcamera/meson.build
diff options
context:
space:
mode:
authorJacopo Mondi <jacopo@jmondi.org>2019-06-12 13:14:10 +0100
committerJacopo Mondi <jacopo@jmondi.org>2019-06-19 15:46:44 +0200
commitd6bb56a90a52deeac4209b346a836ff9d9068ddd (patch)
tree6108af0443155ca6f7c2cb39cdcc2e7ed0d0767d /src/libcamera/meson.build
parent3a6c4bd146cc6647daf458bbc048bd861e702f62 (diff)
libcamera: Introduce V4L2Device base class
The V4L2 devices and subdevices share a few common operations,like opening and closing a device node, and perform IOCTLs on the device. With the forthcoming introduction of support for V4L2 controls, the quantity of shared code will increase, as the control support implementation is identical for the two derived classes. To maximize code re-use and avoid duplications, provide a V4L2Device base class which groups the common operations and members. The newly introduced base class provides methods to open/close a device node, access the file descriptor, and perform IOCTLs on the device. Signed-off-by: Jacopo Mondi <jacopo@jmondi.org> Signed-off-by: Kieran Bingham <kieran.bingham@ideasonboard.com> Reviewed-by: Kieran Bingham <kieran.bingham@ideasonboard.com> Reviewed-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com>
Diffstat (limited to 'src/libcamera/meson.build')
-rw-r--r--src/libcamera/meson.build2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/libcamera/meson.build b/src/libcamera/meson.build
index 15ab53b1..f26ad5b2 100644
--- a/src/libcamera/meson.build
+++ b/src/libcamera/meson.build
@@ -23,6 +23,7 @@ libcamera_sources = files([
'stream.cpp',
'timer.cpp',
'utils.cpp',
+ 'v4l2_device.cpp',
'v4l2_subdevice.cpp',
'v4l2_videodevice.cpp',
])
@@ -41,6 +42,7 @@ libcamera_headers = files([
'include/media_object.h',
'include/pipeline_handler.h',
'include/utils.h',
+ 'include/v4l2_device.h',
'include/v4l2_subdevice.h',
'include/v4l2_videodevice.h',
])