summaryrefslogtreecommitdiff
path: root/src/libcamera/meson.build
diff options
context:
space:
mode:
authorLaurent Pinchart <laurent.pinchart@ideasonboard.com>2020-09-16 16:04:03 +0300
committerLaurent Pinchart <laurent.pinchart@ideasonboard.com>2020-09-16 18:15:28 +0300
commitd5ce2679c67877295ce0096afd3d24d28ad34d16 (patch)
tree460048faef4fd8b869edfaf60845b554a42cf588 /src/libcamera/meson.build
parentde20029a582a71a87d99388a62fb63c86e85028a (diff)
libcamera: Turn the android option into a feature
Allow disabling compilation of the Android HAL adaptation layer automatically when a dependency is missing by turning the android option into a feature. The default value is set to 'disabled' to match the current behaviour. Signed-off-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> Reviewed-by: Kieran Bingham <kieran.bingham@ideasonboard.com> Reviewed-by: Niklas Söderlund <niklas.soderlund@ragnatech.se>
Diffstat (limited to 'src/libcamera/meson.build')
-rw-r--r--src/libcamera/meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/libcamera/meson.build b/src/libcamera/meson.build
index af2f3d95..0e6ecf50 100644
--- a/src/libcamera/meson.build
+++ b/src/libcamera/meson.build
@@ -121,7 +121,7 @@ libcamera_deps = [
libcamera_link_with = []
-if get_option('android')
+if android_enabled
libcamera_sources += android_hal_sources
includes += android_includes
libcamera_link_with += android_camera_metadata