summaryrefslogtreecommitdiff
path: root/src/libcamera/meson.build
diff options
context:
space:
mode:
authorPaul Elder <paul.elder@ideasonboard.com>2019-05-10 19:09:29 -0400
committerPaul Elder <paul.elder@ideasonboard.com>2019-05-21 18:31:37 -0400
commitc1bbbd3b5b4706a31a7505fdd9ad65786764e2d7 (patch)
treea7324253b1bc1d621b61be3e0c68f7a8600b5498 /src/libcamera/meson.build
parent06387039d6f59f8cb1829edfc09d2d9c8b33d62c (diff)
libcamera: ipa_module: add IPA shared library module
Implement a class to wrap around an IPA module shared object. For now, just load a struct IPAModuleInfo with symbol name ipaModuleInfo from an IPA module .so shared object. Also provide a public header file including the struct IPAModuleInfo, structured such that both C and C++ IPA modules are supported. Signed-off-by: Paul Elder <paul.elder@ideasonboard.com> Reviewed-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com>
Diffstat (limited to 'src/libcamera/meson.build')
-rw-r--r--src/libcamera/meson.build2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/libcamera/meson.build b/src/libcamera/meson.build
index 8796f49b..e5b48f22 100644
--- a/src/libcamera/meson.build
+++ b/src/libcamera/meson.build
@@ -10,6 +10,7 @@ libcamera_sources = files([
'event_notifier.cpp',
'formats.cpp',
'geometry.cpp',
+ 'ipa_module.cpp',
'log.cpp',
'media_device.cpp',
'media_object.cpp',
@@ -31,6 +32,7 @@ libcamera_headers = files([
'include/device_enumerator_udev.h',
'include/event_dispatcher_poll.h',
'include/formats.h',
+ 'include/ipa_module.h',
'include/log.h',
'include/media_device.h',
'include/media_object.h',