summaryrefslogtreecommitdiff
path: root/src/libcamera/meson.build
diff options
context:
space:
mode:
authorLaurent Pinchart <laurent.pinchart@ideasonboard.com>2020-04-15 22:27:33 +0300
committerLaurent Pinchart <laurent.pinchart@ideasonboard.com>2020-04-16 17:34:08 +0300
commitb7c5e0e4f0e922c6988c68af6a64c31b071ad696 (patch)
tree799071e5f07acfaef0936c6b7c404ea01c7f67b1 /src/libcamera/meson.build
parent2155a9b74ea3cc3bc0295c5709749520ffacdf6b (diff)
libcamera: Make IPA module signing optional
The IPA module signing mechanism relies on openssl to generate keys and sign the module. If openssl is not found on the system, the build will fail. Make the dependency optional by detecting openssl, and skip generation of signatures if openssl isn't found. Signed-off-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> Reviewed-by: Kieran Bingham <kieran.bingham@ideasonboard.com>
Diffstat (limited to 'src/libcamera/meson.build')
-rw-r--r--src/libcamera/meson.build16
1 files changed, 9 insertions, 7 deletions
diff --git a/src/libcamera/meson.build b/src/libcamera/meson.build
index c502450c..dcd2fb49 100644
--- a/src/libcamera/meson.build
+++ b/src/libcamera/meson.build
@@ -101,13 +101,15 @@ version_cpp = vcs_tag(command : [gen_version, meson.build_root()],
libcamera_sources += version_cpp
-gen_ipa_pub_key = files('gen-ipa-pub-key.py')
-ipa_pub_key_cpp = custom_target('ipa_pub_key_cpp',
- input : [ ipa_priv_key, 'ipa_pub_key.cpp.in' ],
- output : 'ipa_pub_key.cpp',
- command : [ gen_ipa_pub_key, '@INPUT@', '@OUTPUT@' ])
-
-libcamera_sources += ipa_pub_key_cpp
+if ipa_sign_module
+ gen_ipa_pub_key = files('gen-ipa-pub-key.py')
+ ipa_pub_key_cpp = custom_target('ipa_pub_key_cpp',
+ input : [ ipa_priv_key, 'ipa_pub_key.cpp.in' ],
+ output : 'ipa_pub_key.cpp',
+ command : [ gen_ipa_pub_key, '@INPUT@', '@OUTPUT@' ])
+
+ libcamera_sources += ipa_pub_key_cpp
+endif
libcamera_deps = [
libatomic,