summaryrefslogtreecommitdiff
path: root/src/libcamera/meson.build
diff options
context:
space:
mode:
authorLaurent Pinchart <laurent.pinchart@ideasonboard.com>2020-05-15 18:55:19 +0300
committerLaurent Pinchart <laurent.pinchart@ideasonboard.com>2020-05-18 12:56:20 +0300
commitaa7e7175c7c7407ef0d6400055dfec5086b31f3b (patch)
tree7ea7cd6149eaceba64ede5d86447093dcc8a238c /src/libcamera/meson.build
parentf934fd1cb9371dc49e32aee061284a2dadd8ea89 (diff)
meson: Rename variables storing headers lists
The list of public, IPA and internal header files are stored in three meson variables, named libcamera_api, libcamera_ipa_api and libcamera_headers respectively. The lack of uniformity is a bit confusing. Fix it by renaming those variables to libcamera_public_headers, libcamera_ipa_headers and libcamera_internal_headers. Signed-off-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> Acked-by: Jacopo Mondi <jacopo@jmondi.org> Acked-by: Kieran Bingham <kieran.bingham@ideasonboard.com>
Diffstat (limited to 'src/libcamera/meson.build')
-rw-r--r--src/libcamera/meson.build5
1 files changed, 4 insertions, 1 deletions
diff --git a/src/libcamera/meson.build b/src/libcamera/meson.build
index 472af451..b88f295d 100644
--- a/src/libcamera/meson.build
+++ b/src/libcamera/meson.build
@@ -138,7 +138,10 @@ libcamera = shared_library('camera',
build_rpath : '/',
dependencies : libcamera_deps)
-libcamera_dep = declare_dependency(sources : [libcamera_api, libcamera_ipa_api],
+libcamera_dep = declare_dependency(sources : [
+ libcamera_ipa_headers,
+ libcamera_public_headers,
+ ],
include_directories : libcamera_includes,
link_with : libcamera)