summaryrefslogtreecommitdiff
path: root/src/libcamera/meson.build
diff options
context:
space:
mode:
authorKieran Bingham <kieran.bingham@ideasonboard.com>2020-06-24 14:15:15 +0100
committerKieran Bingham <kieran.bingham@ideasonboard.com>2020-08-06 15:46:02 +0100
commit998f4de65ebccf638b19a90172db74b2dc469c78 (patch)
treee4fc1bb0369963e31674c7ce708f078b9e62e93a /src/libcamera/meson.build
parentc09aee4ccb7043484047d060f7f8bc1e0192ea23 (diff)
android: Introduce JPEG encoding
Provide an encoder interface and implement a JPEG encoder using libjpeg. Reviewed-by: Jacopo Mondi <jacopo@jmondi.org> Signed-off-by: Kieran Bingham <kieran.bingham@ideasonboard.com>
Diffstat (limited to 'src/libcamera/meson.build')
-rw-r--r--src/libcamera/meson.build2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/libcamera/meson.build b/src/libcamera/meson.build
index bada45bc..af2f3d95 100644
--- a/src/libcamera/meson.build
+++ b/src/libcamera/meson.build
@@ -125,6 +125,8 @@ if get_option('android')
libcamera_sources += android_hal_sources
includes += android_includes
libcamera_link_with += android_camera_metadata
+
+ libcamera_deps += android_deps
endif
# We add '/' to the build_rpath as a 'safe' path to act as a boolean flag.