summaryrefslogtreecommitdiff
path: root/src/libcamera/meson.build
diff options
context:
space:
mode:
authorLaurent Pinchart <laurent.pinchart@ideasonboard.com>2019-02-08 00:24:14 +0200
committerLaurent Pinchart <laurent.pinchart@ideasonboard.com>2019-02-13 13:23:43 +0200
commit98bd9cb8c9f370c977dc3b6cc14f3d1ebfd24563 (patch)
tree037e1a54f52db97ee12ab89d8343fcab80cf5c15 /src/libcamera/meson.build
parent73a1bea709fd14cab11f35a99e9feaa98a42c3cc (diff)
libcamera: signal: Disconnect signal automatically on slot deletion
When a signal is connected to a member function slot, the slot is not disconnected when the slot object is deleted. This can lead to calling a member function of a deleted object if the signal isn't disconnected manually by the slot object's destructor. Make signal handling easier by implementing a base Object class that tracks all connected signals and disconnects from them automatically when the object is deleted, using template specialization resolution in the Signal class. As inheriting from the Object class may to a too harsh requirement for Signal usage in applications, keep the existing behaviour working if the slot doesn't inherit from the Object class. We may reconsider this later and require all slot objects to inherit from the Object class. Signed-off-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> Reviewed-by: Niklas Söderlund <niklas.soderlund@ragnatech.se>
Diffstat (limited to 'src/libcamera/meson.build')
-rw-r--r--src/libcamera/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/libcamera/meson.build b/src/libcamera/meson.build
index c5354c13..8384cd0a 100644
--- a/src/libcamera/meson.build
+++ b/src/libcamera/meson.build
@@ -10,6 +10,7 @@ libcamera_sources = files([
'log.cpp',
'media_device.cpp',
'media_object.cpp',
+ 'object.cpp',
'pipeline_handler.cpp',
'request.cpp',
'signal.cpp',