summaryrefslogtreecommitdiff
path: root/src/libcamera/meson.build
diff options
context:
space:
mode:
authorJacopo Mondi <jacopo@jmondi.org>2021-11-15 19:01:56 +0100
committerJacopo Mondi <jacopo@jmondi.org>2021-12-11 17:53:40 +0100
commit8ac8ecb1e12f18891369bb26693bc3a0a7d6ff94 (patch)
tree57d71939ed2b2cca0baca6bd6606e7776bfd1b78 /src/libcamera/meson.build
parentdb37335ee0ee78f7e5562a9617c1b4f17451fc3a (diff)
libcamera: fence: Introduce Fence
Introduce a Fence class which models a synchronization primitive that allows to notify the availability of a resource. The Fence is modeled as a wrapper of a UniqueFD instance where read events are used to signal the Fence. The class can be later extended to support additional signalling mechanisms. Signed-off-by: Jacopo Mondi <jacopo@jmondi.org> Reviewed-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com>
Diffstat (limited to 'src/libcamera/meson.build')
-rw-r--r--src/libcamera/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/libcamera/meson.build b/src/libcamera/meson.build
index 2e54cc04..dc1cc52a 100644
--- a/src/libcamera/meson.build
+++ b/src/libcamera/meson.build
@@ -15,6 +15,7 @@ libcamera_sources = files([
'delayed_controls.cpp',
'device_enumerator.cpp',
'device_enumerator_sysfs.cpp',
+ 'fence.cpp',
'formats.cpp',
'framebuffer.cpp',
'framebuffer_allocator.cpp',