summaryrefslogtreecommitdiff
path: root/src/libcamera/meson.build
diff options
context:
space:
mode:
authorPaul Elder <paul.elder@ideasonboard.com>2019-06-03 13:19:44 -0400
committerPaul Elder <paul.elder@ideasonboard.com>2019-06-05 10:44:52 -0400
commit7fa98a4cdd296c86fe053ab17486c1e0e2a72e90 (patch)
treed038f64587b41f02f9ec928a6181ec72589b5b97 /src/libcamera/meson.build
parent42c9b4bad40b462ef267b477e136202f02071137 (diff)
libcamera: ipa_manager: implement class for managing IPA modules
IPAManager is a class that will search in given directories for IPA modules, and will load them into a list. It also provides an interface for pipeline handlers to acquire an IPA. A meson build file for the IPAs is added, which also specifies a hard-coded path for where to load the IPAs from in the installation directory. More paths can be specified with the environment variable LIBCAMERA_IPA_MODULE_PATH, with the same syntax as the regular PATH environment variable. Make the test framework set this environment variable. Signed-off-by: Paul Elder <paul.elder@ideasonboard.com> Reviewed-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com>
Diffstat (limited to 'src/libcamera/meson.build')
-rw-r--r--src/libcamera/meson.build2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/libcamera/meson.build b/src/libcamera/meson.build
index 32f7da4d..0889b0d3 100644
--- a/src/libcamera/meson.build
+++ b/src/libcamera/meson.build
@@ -11,6 +11,7 @@ libcamera_sources = files([
'formats.cpp',
'geometry.cpp',
'ipa_interface.cpp',
+ 'ipa_manager.cpp',
'ipa_module.cpp',
'log.cpp',
'media_device.cpp',
@@ -33,6 +34,7 @@ libcamera_headers = files([
'include/device_enumerator_udev.h',
'include/event_dispatcher_poll.h',
'include/formats.h',
+ 'include/ipa_manager.h',
'include/ipa_module.h',
'include/log.h',
'include/media_device.h',