summaryrefslogtreecommitdiff
path: root/src/libcamera/meson.build
diff options
context:
space:
mode:
authorLaurent Pinchart <laurent.pinchart@ideasonboard.com>2019-04-10 01:18:49 +0300
committerLaurent Pinchart <laurent.pinchart@ideasonboard.com>2019-04-18 18:13:17 +0300
commit7645083c720f419d6188b40fa94af95146c346cb (patch)
tree7478f929838f6e01cbe0aa807f205c3a84c0a4ae /src/libcamera/meson.build
parent05b0e5ed531553ad20c4c787de3c337425e6b907 (diff)
libcamera: camera_sensor: Add a new class to model a camera sensor
The CameraSensor class abstracts camera sensors and provides helper functions to ease interactions with them. It is currently limited to sensors that expose a single subdev, and offer the same frame sizes for all media bus codes, but will be extended to support more complex sensors as the needs arise. Signed-off-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> Reviewed-by: Niklas Söderlund <niklas.soderlund@ragnatech.se> Reviewed-by: Jacopo Mondi <jacopo@jmondi.org>
Diffstat (limited to 'src/libcamera/meson.build')
-rw-r--r--src/libcamera/meson.build2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/libcamera/meson.build b/src/libcamera/meson.build
index cd36ac30..cf4edec0 100644
--- a/src/libcamera/meson.build
+++ b/src/libcamera/meson.build
@@ -2,6 +2,7 @@ libcamera_sources = files([
'buffer.cpp',
'camera.cpp',
'camera_manager.cpp',
+ 'camera_sensor.cpp',
'device_enumerator.cpp',
'event_dispatcher.cpp',
'event_dispatcher_poll.cpp',
@@ -23,6 +24,7 @@ libcamera_sources = files([
])
libcamera_headers = files([
+ 'include/camera_sensor.h',
'include/device_enumerator.h',
'include/event_dispatcher_poll.h',
'include/formats.h',