summaryrefslogtreecommitdiff
path: root/src/libcamera/meson.build
diff options
context:
space:
mode:
authorJacopo Mondi <jacopo@jmondi.org>2019-10-22 01:52:08 +0200
committerLaurent Pinchart <laurent.pinchart@ideasonboard.com>2019-11-20 21:47:49 +0200
commit69bb53aca1cdb5861fd19b3b1345d20e4139e938 (patch)
treeb2ecc0b5ffc2c898b32993035da276e8e3c0ef9c /src/libcamera/meson.build
parent4e5e352f3b43fed96987a78eae90f144f26ed7a1 (diff)
libcamera: Add ByteStreamBuffer
The ByteStreamBuffer class wraps a memory area, expected to be allocated by the user of the class and provides operations to perform sequential access in read and write modes. Signed-off-by: Jacopo Mondi <jacopo@jmondi.org> Signed-off-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com>
Diffstat (limited to 'src/libcamera/meson.build')
-rw-r--r--src/libcamera/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/libcamera/meson.build b/src/libcamera/meson.build
index be0cd53f..dab2d8ad 100644
--- a/src/libcamera/meson.build
+++ b/src/libcamera/meson.build
@@ -1,6 +1,7 @@
libcamera_sources = files([
'bound_method.cpp',
'buffer.cpp',
+ 'byte_stream_buffer.cpp',
'camera.cpp',
'camera_controls.cpp',
'camera_manager.cpp',