summaryrefslogtreecommitdiff
path: root/src/libcamera/meson.build
diff options
context:
space:
mode:
authorJacopo Mondi <jacopo@jmondi.org>2019-05-10 17:40:02 +0200
committerJacopo Mondi <jacopo@jmondi.org>2019-08-12 11:55:46 +0200
commit667d8ea8fd4bda35e8888792d2b6c055fdb4be18 (patch)
tree786462c9f8dfce3d3d05d69dc8befcd67e94db07 /src/libcamera/meson.build
parent6bed34da161bb8c4e86821116dcff2205e29c58a (diff)
android: hal: Add Camera3 HAL
Add libcamera Android Camera HALv3 implementation. The initial camera HAL implementation supports the LIMITED hardware level and uses statically defined metadata and camera characteristics. Add a build option named 'android' and adjust the build system to selectively compile the Android camera HAL and link it against the required Android libraries. Signed-off-by: Jacopo Mondi <jacopo@jmondi.org>
Diffstat (limited to 'src/libcamera/meson.build')
-rw-r--r--src/libcamera/meson.build9
1 files changed, 9 insertions, 0 deletions
diff --git a/src/libcamera/meson.build b/src/libcamera/meson.build
index a09b23d6..7d5d3c04 100644
--- a/src/libcamera/meson.build
+++ b/src/libcamera/meson.build
@@ -103,9 +103,18 @@ libcamera_deps = [
dependency('threads'),
]
+libcamera_link_with = []
+
+if get_option('android')
+ libcamera_sources += android_hal_sources
+ includes += android_includes
+ libcamera_link_with += android_camera_metadata
+endif
+
libcamera = shared_library('camera',
libcamera_sources,
install : true,
+ link_with : libcamera_link_with,
include_directories : includes,
dependencies : libcamera_deps)