summaryrefslogtreecommitdiff
path: root/src/libcamera/meson.build
diff options
context:
space:
mode:
authorKieran Bingham <kieran.bingham@ideasonboard.com>2021-04-30 14:18:52 +0100
committerKieran Bingham <kieran.bingham@ideasonboard.com>2021-06-25 16:09:46 +0100
commit63c46875376031141e6e9bda694dcb5d59fb8d4b (patch)
tree72d2a298b3f90620d63db0e36892e949acebe752 /src/libcamera/meson.build
parent53a0d80af0f9983d6bc0d54b0e85403a08721488 (diff)
android: Split HAL to its own shared library
The libcamera Android HAL implementation should not be an integral part of libcamera, but a support library that utilises the libcamera public API. Move the implementation to its own distinct library. Reviewed-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> Reviewed-by: Hirokazu Honda <hiroh@chromium.org> Reviewed-by: Umang Jain <umang.jain@ideasonboard.com> Reviewed-by: Paul Elder <paul.elder@ideasonboard.com> Signed-off-by: Kieran Bingham <kieran.bingham@ideasonboard.com>
Diffstat (limited to 'src/libcamera/meson.build')
-rw-r--r--src/libcamera/meson.build13
1 files changed, 0 insertions, 13 deletions
diff --git a/src/libcamera/meson.build b/src/libcamera/meson.build
index 7e19a177..d9b5bfae 100644
--- a/src/libcamera/meson.build
+++ b/src/libcamera/meson.build
@@ -130,16 +130,6 @@ libcamera_deps = [
dependency('threads'),
]
-libcamera_link_with = []
-
-if android_enabled
- libcamera_sources += android_hal_sources
- includes += android_includes
- libcamera_link_with += android_camera_metadata
-
- libcamera_deps += android_deps
-endif
-
# We add '/' to the build_rpath as a 'safe' path to act as a boolean flag.
# The build_rpath is stripped at install time by meson, so we determine at
# runtime if the library is running from an installed location by checking
@@ -148,10 +138,7 @@ endif
libcamera = shared_library('camera',
libcamera_sources,
install : true,
- link_with : libcamera_link_with,
- cpp_args : libcamera_cpp_args,
include_directories : includes,
- objects : libcamera_objects,
build_rpath : '/',
dependencies : libcamera_deps)