summaryrefslogtreecommitdiff
path: root/src/libcamera/meson.build
diff options
context:
space:
mode:
authorLaurent Pinchart <laurent.pinchart@ideasonboard.com>2020-03-29 04:52:30 +0300
committerLaurent Pinchart <laurent.pinchart@ideasonboard.com>2020-04-14 02:03:28 +0300
commit4b11facde4ef3499690b84428c6155bea867fba8 (patch)
tree7ec5df3468ac94b253bea091adcc419a3cf2e580 /src/libcamera/meson.build
parent462d6508a29c78788fe7f88d6cfe304a6aa4b8c4 (diff)
libcamera: ipa_manager: Embed IPA module signing public key
In preparation for verifying the signature of IPA modules, generate a public key from the private signing key and embed it in the IPAManager class. Signed-off-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> Reviewed-by: Niklas Söderlund <niklas.soderlund@ragnatech.se>
Diffstat (limited to 'src/libcamera/meson.build')
-rw-r--r--src/libcamera/meson.build8
1 files changed, 8 insertions, 0 deletions
diff --git a/src/libcamera/meson.build b/src/libcamera/meson.build
index c2a657e4..c502450c 100644
--- a/src/libcamera/meson.build
+++ b/src/libcamera/meson.build
@@ -101,6 +101,14 @@ version_cpp = vcs_tag(command : [gen_version, meson.build_root()],
libcamera_sources += version_cpp
+gen_ipa_pub_key = files('gen-ipa-pub-key.py')
+ipa_pub_key_cpp = custom_target('ipa_pub_key_cpp',
+ input : [ ipa_priv_key, 'ipa_pub_key.cpp.in' ],
+ output : 'ipa_pub_key.cpp',
+ command : [ gen_ipa_pub_key, '@INPUT@', '@OUTPUT@' ])
+
+libcamera_sources += ipa_pub_key_cpp
+
libcamera_deps = [
libatomic,
libdl,