summaryrefslogtreecommitdiff
path: root/src/libcamera/meson.build
diff options
context:
space:
mode:
authorNiklas Söderlund <niklas.soderlund@ragnatech.se>2020-10-27 01:08:23 +0100
committerNiklas Söderlund <niklas.soderlund@ragnatech.se>2021-01-29 15:35:28 +0100
commit3d4b7b0059116f5f151dec5090ec0e18bd401f24 (patch)
tree999c57f020ca4bb91439c96c1f67cb2ac200b13e /src/libcamera/meson.build
parent958c80a4f1c28301ce19112e04de55a6a5102dad (diff)
libcamera: delayed_controls: Add helper for controls that apply with a delay
Some sensor controls take effect with a delay as the sensor needs time to adjust, for example exposure. Add an optional helper DelayedControls to help pipelines deal with such controls. The idea is to provide a queue of controls towards the V4L2 device and apply individual controls with the specified delay with the aim to get predictable and retrievable control values for any given frame. To do this the queue of controls needs to be at least as deep as the control with the largest delay. The DelayedControls needs to be informed of every start of exposure. This can be emulated but the helper is designed to be used with this event being provide by the kernel through V4L2 events. This helper is based on StaggeredCtrl from the Raspberry Pi pipeline handler but expands on its API. This helpers aims to replace the Raspberry Pi implementations and mimics it behavior perfectly. Signed-off-by: Niklas Söderlund <niklas.soderlund@ragnatech.se> Reviewed-by: Jacopo Mondi <jacopo@jmondi.org> Reviewed-by: Naushir Patuck <naush@raspberrypi.com>
Diffstat (limited to 'src/libcamera/meson.build')
-rw-r--r--src/libcamera/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/libcamera/meson.build b/src/libcamera/meson.build
index 387d5d88..5a4bf0d7 100644
--- a/src/libcamera/meson.build
+++ b/src/libcamera/meson.build
@@ -12,6 +12,7 @@ libcamera_sources = files([
'controls.cpp',
'control_serializer.cpp',
'control_validator.cpp',
+ 'delayed_controls.cpp',
'device_enumerator.cpp',
'device_enumerator_sysfs.cpp',
'event_dispatcher.cpp',