summaryrefslogtreecommitdiff
path: root/src/libcamera/meson.build
diff options
context:
space:
mode:
authorUmang Jain <umang.jain@ideasonboard.com>2021-05-07 11:28:40 +0530
committerKieran Bingham <kieran.bingham@ideasonboard.com>2021-05-11 11:50:45 +0100
commit17bf7df22762b0ecb64d0c72baed608a90363199 (patch)
tree70144f7932e8b2e7b1ee7f83c1852c4ccf7faffd /src/libcamera/meson.build
parent99feb66df02988831c9e8535649b99fad9a78069 (diff)
meson: Replace obselete join_paths() with '/' operator
Since meson v0.49.0, join_paths() is equivalent to '/' hence, drop and replace it with '/' short-hand in meson files. This commit does not introduce any functional changes. Signed-off-by: Umang Jain <umang.jain@ideasonboard.com> Reviewed-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> Reviewed-by: Kieran Bingham <kieran.bingham@ideasonboard.com> Signed-off-by: Kieran Bingham <kieran.bingham@ideasonboard.com>
Diffstat (limited to 'src/libcamera/meson.build')
-rw-r--r--src/libcamera/meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/libcamera/meson.build b/src/libcamera/meson.build
index 675053d4..7bc59b84 100644
--- a/src/libcamera/meson.build
+++ b/src/libcamera/meson.build
@@ -103,7 +103,7 @@ endforeach
libcamera_sources += control_sources
-gen_version = join_paths(meson.source_root(), 'utils', 'gen-version.sh')
+gen_version = meson.source_root() / 'utils' / 'gen-version.sh'
version_cpp = vcs_tag(command : [gen_version, meson.build_root()],
input : 'version.cpp.in',