summaryrefslogtreecommitdiff
path: root/src/libcamera/meson.build
diff options
context:
space:
mode:
authorPaul Elder <paul.elder@ideasonboard.com>2019-07-10 20:29:44 +0900
committerPaul Elder <paul.elder@ideasonboard.com>2019-07-11 12:22:40 +0900
commit10ec09025d6f52f2c1d0ba6b7e6943a603a386d9 (patch)
tree88155bb4924380641b1212219f5b697b121177ca /src/libcamera/meson.build
parent6a27bd33879970e182949ad2010687886d2dc671 (diff)
libcamera: skip auto version generation when building for Chromium OS
Commit b817bcec6b53 ("libcamera: Auto generate version information") causes the build to fail in the Chromium OS build environment, because git update-index tries to take a lock (ie. write) in the git repo that is outside of the build directory. The solution is to simply skip git update-index if we are building in the Chromium OS build environment, and this decision is made if the build directory is not a subdirectory of the source directory. Signed-off-by: Paul Elder <paul.elder@ideasonboard.com> Reviewed-by: Kieran Bingham <kieran.bingham@ideasonboard.com> Reviewed-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com>
Diffstat (limited to 'src/libcamera/meson.build')
-rw-r--r--src/libcamera/meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/libcamera/meson.build b/src/libcamera/meson.build
index 97ff86e2..adc749ec 100644
--- a/src/libcamera/meson.build
+++ b/src/libcamera/meson.build
@@ -81,7 +81,7 @@ libcamera_sources += control_types_cpp
gen_version = join_paths(meson.source_root(), 'utils', 'gen-version.sh')
-version_cpp = vcs_tag(command : [gen_version, meson.source_root()],
+version_cpp = vcs_tag(command : [gen_version, meson.build_root()],
input : 'version.cpp.in',
output : 'version.cpp',
fallback : meson.project_version())