summaryrefslogtreecommitdiff
path: root/src/libcamera/meson.build
diff options
context:
space:
mode:
authorKieran Bingham <kieran.bingham@ideasonboard.com>2018-12-10 13:48:15 +0000
committerKieran Bingham <kieran.bingham@ideasonboard.com>2019-04-03 13:56:10 +0700
commit0e1a80952524e672ce8ce5eb900740dda2ae9044 (patch)
tree4ceef54b377004b18f1da8986f9393203aea8992 /src/libcamera/meson.build
parentabda899fa920ee891e3c6f1b8da79bd77eb28784 (diff)
libcamera: utils: Use internal basename implementation.
Differing implementations of basename() exist, some of which may modify the content of the string passed as an argument. The implementation of basename() is trivial, thus to support different C librariese, provide our own version which accepts and returns a const char *. Update the call sites to use the new implementation. Reviewed-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> Signed-off-by: Kieran Bingham <kieran.bingham@ideasonboard.com>
Diffstat (limited to 'src/libcamera/meson.build')
-rw-r--r--src/libcamera/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/libcamera/meson.build b/src/libcamera/meson.build
index 4433abfc..b2fe0e4f 100644
--- a/src/libcamera/meson.build
+++ b/src/libcamera/meson.build
@@ -17,6 +17,7 @@ libcamera_sources = files([
'signal.cpp',
'stream.cpp',
'timer.cpp',
+ 'utils.cpp',
'v4l2_device.cpp',
'v4l2_subdevice.cpp',
])