summaryrefslogtreecommitdiff
path: root/src/libcamera/meson.build
diff options
context:
space:
mode:
authorLaurent Pinchart <laurent.pinchart@ideasonboard.com>2019-03-24 03:21:28 +0200
committerLaurent Pinchart <laurent.pinchart@ideasonboard.com>2019-07-11 10:20:15 +0300
commit01b930964acdd9475d46044c459396f8c3cf8a79 (patch)
treee7f4625cd315426dba6da7caa2d559eca458b14c /src/libcamera/meson.build
parent525b19c4101235385148ff9358b7b6e778a1f148 (diff)
libcamera: thread: Add a messaging passing API
Create a new Message class to model a message that can be passed to an object living in another thread. Only an invalid message type is currently defined, more messages will be added in the future. The Thread class is extended with a messages queue, and the Object class with thread affinity. Signed-off-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> Reviewed-by: Niklas Söderlund <niklas.soderlund@ragnatech.se>
Diffstat (limited to 'src/libcamera/meson.build')
-rw-r--r--src/libcamera/meson.build2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/libcamera/meson.build b/src/libcamera/meson.build
index bad60da4..eda506b2 100644
--- a/src/libcamera/meson.build
+++ b/src/libcamera/meson.build
@@ -18,6 +18,7 @@ libcamera_sources = files([
'log.cpp',
'media_device.cpp',
'media_object.cpp',
+ 'message.cpp',
'object.cpp',
'pipeline_handler.cpp',
'request.cpp',
@@ -45,6 +46,7 @@ libcamera_headers = files([
'include/log.h',
'include/media_device.h',
'include/media_object.h',
+ 'include/message.h',
'include/pipeline_handler.h',
'include/thread.h',
'include/utils.h',