summaryrefslogtreecommitdiff
path: root/src/lc-compliance/meson.build
diff options
context:
space:
mode:
authorLaurent Pinchart <laurent.pinchart@ideasonboard.com>2022-10-20 00:44:55 +0300
committerLaurent Pinchart <laurent.pinchart@ideasonboard.com>2022-10-20 13:36:25 +0300
commit84ad104499d9efc0253dae1a60ee070ed375ad95 (patch)
treed10fd53eb79cebb28fa3f72b18b46dddb6382b83 /src/lc-compliance/meson.build
parentdaf3f4b59f4ea0ecb42c6a39fe909f071d3a2842 (diff)
Move test applications to src/apps/
The cam and qcam test application share code, currently through a crude hack that references the cam source files directly from the qcam meson.build file. To prepare for the introduction of hosting that code in a static library, move all applications to src/apps/. Signed-off-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> Reviewed-by: Paul Elder <paul.elder@ideasonboard.com> Reviewed-by: Kieran Bingham <kieran.bingham@ideasonboard.com>
Diffstat (limited to 'src/lc-compliance/meson.build')
-rw-r--r--src/lc-compliance/meson.build31
1 files changed, 0 insertions, 31 deletions
diff --git a/src/lc-compliance/meson.build b/src/lc-compliance/meson.build
deleted file mode 100644
index 8b57474b..00000000
--- a/src/lc-compliance/meson.build
+++ /dev/null
@@ -1,31 +0,0 @@
-# SPDX-License-Identifier: CC0-1.0
-
-libevent = dependency('libevent_pthreads', required : get_option('lc-compliance'))
-libgtest = dependency('gtest', required : get_option('lc-compliance'),
- fallback : ['gtest', 'gtest_dep'])
-
-if not (libevent.found() and libgtest.found())
- lc_compliance_enabled = false
- subdir_done()
-endif
-
-lc_compliance_enabled = true
-
-lc_compliance_sources = files([
- '../cam/event_loop.cpp',
- '../cam/options.cpp',
- 'environment.cpp',
- 'main.cpp',
- 'simple_capture.cpp',
- 'capture_test.cpp',
-])
-
-lc_compliance = executable('lc-compliance', lc_compliance_sources,
- cpp_args : [ '-fexceptions' ],
- dependencies : [
- libatomic,
- libcamera_public,
- libevent,
- libgtest,
- ],
- install : true)