summaryrefslogtreecommitdiff
path: root/src/ipa/vimc/meson.build
diff options
context:
space:
mode:
authorLaurent Pinchart <laurent.pinchart@ideasonboard.com>2020-03-25 09:36:35 +0200
committerLaurent Pinchart <laurent.pinchart@ideasonboard.com>2020-03-25 12:21:06 +0200
commita25533089bda04daf0243eda7e316baea0737e19 (patch)
tree8997f2c22a0861e0da134a9a1c099f02bd9a7f57 /src/ipa/vimc/meson.build
parent5e8933eeebcedda55d4c4e84db9b4983eecefe1b (diff)
ipa: Move vimc to a subdirectory
Give a subdirectory to all IPA modules to make the structure of the source tree more consistent. This will also simplify the implementation of IPA module selection at build time. Signed-off-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> Reviewed-by: Kieran Bingham <kieran.bingham@ideasonboard.com> Reviewed-by: Niklas Söderlund <niklas.soderlund@ragnatech.se>
Diffstat (limited to 'src/ipa/vimc/meson.build')
-rw-r--r--src/ipa/vimc/meson.build15
1 files changed, 15 insertions, 0 deletions
diff --git a/src/ipa/vimc/meson.build b/src/ipa/vimc/meson.build
new file mode 100644
index 00000000..435c7d31
--- /dev/null
+++ b/src/ipa/vimc/meson.build
@@ -0,0 +1,15 @@
+ipa_vimc_sources = [
+ ['ipa_vimc', 'LGPL-2.1-or-later'],
+ ['ipa_vimc_isolate', 'Proprietary'],
+]
+
+foreach t : ipa_vimc_sources
+ ipa = shared_module(t[0], 'vimc.cpp',
+ name_prefix : '',
+ include_directories : [ipa_includes, libipa_includes],
+ dependencies : libcamera_dep,
+ link_with : libipa,
+ install : true,
+ install_dir : ipa_install_dir,
+ cpp_args : '-DLICENSE="' + t[1] + '"')
+endforeach