summaryrefslogtreecommitdiff
path: root/src/ipa/simple/meson.build
diff options
context:
space:
mode:
authorMilan Zamazal <mzamazal@redhat.com>2024-09-27 15:46:14 +0200
committerKieran Bingham <kieran.bingham@ideasonboard.com>2024-09-27 15:01:57 +0100
commit97f9961e1bc85bec29d3d3b1cba05f46d83f4c27 (patch)
tree2b8e1c805d1eef22dd307c9847c51941621889e4 /src/ipa/simple/meson.build
parentf06c344bd5cfc3ae1492b73a82b1d4050bec06fc (diff)
libcamera: software_isp: Create algorithms
We are ready to introduce algorithms now. First, let's create algorithms. The algorithms are not called yet, calls to them will be added in followup patches. The maximum number of contexts is set to the same value as in hardware pipelines. Signed-off-by: Milan Zamazal <mzamazal@redhat.com> Reviewed-by: Umang Jain <umang.jain@ideasonboard.com> Reviewed-by: Daniel Scally <dan.scally@ideasonboard.com> Reviewed-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> Signed-off-by: Kieran Bingham <kieran.bingham@ideasonboard.com>
Diffstat (limited to 'src/ipa/simple/meson.build')
-rw-r--r--src/ipa/simple/meson.build7
1 files changed, 5 insertions, 2 deletions
diff --git a/src/ipa/simple/meson.build b/src/ipa/simple/meson.build
index 7757f99b..dcd7c70a 100644
--- a/src/ipa/simple/meson.build
+++ b/src/ipa/simple/meson.build
@@ -1,5 +1,8 @@
# SPDX-License-Identifier: CC0-1.0
+subdir('algorithms')
+subdir('data')
+
ipa_name = 'ipa_soft_simple'
soft_simple_sources = files([
@@ -8,6 +11,8 @@ soft_simple_sources = files([
'black_level.cpp',
])
+soft_simple_sources += soft_simple_ipa_algorithms
+
mod = shared_module(ipa_name, soft_simple_sources,
name_prefix : '',
include_directories : [ipa_includes],
@@ -24,6 +29,4 @@ if ipa_sign_module
build_by_default : true)
endif
-subdir('data')
-
ipa_names += ipa_name