summaryrefslogtreecommitdiff
path: root/src/ipa/rpi/meson.build
diff options
context:
space:
mode:
authorNaushir Patuck <naush@raspberrypi.com>2023-05-03 13:20:31 +0100
committerLaurent Pinchart <laurent.pinchart@ideasonboard.com>2023-05-04 20:50:15 +0300
commitd903fdbe313a908b9e67024e897323eeca657fb5 (patch)
tree0b42cb054745f51be439994a8770ef367dd8d206 /src/ipa/rpi/meson.build
parentcea3de4226665b25261f63aeb338f846e31b6ac9 (diff)
ipa: raspberrypi: Introduce IpaBase class
Create a new IpaBase class that handles general purpose housekeeping duties for the Raspberry Pi IPA. The implementation of the new class is essentially pulled from the existing ipa/rpi/vc4/raspberrypi.cpp file with a minimal amount of refactoring. Create a derived IpaVc4 class from IpaBase that handles the VC4 pipeline specific tasks of the IPA. Again, code for this class implementation is taken from the existing ipa/rpi/vc4/raspberrypi.cpp with a minimal amount of refactoring. The goal of this change is to allow third parties to implement their own IPA running on the Raspberry Pi without duplicating all of the IPA housekeeping tasks. Signed-off-by: Naushir Patuck <naush@raspberrypi.com> Reviewed-by: Jacopo Mondi <jacopo.mondi@ideasonboard.com> Signed-off-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com>
Diffstat (limited to 'src/ipa/rpi/meson.build')
-rw-r--r--src/ipa/rpi/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/ipa/rpi/meson.build b/src/ipa/rpi/meson.build
index 7d7a61f7..4811c76f 100644
--- a/src/ipa/rpi/meson.build
+++ b/src/ipa/rpi/meson.build
@@ -1,6 +1,7 @@
# SPDX-License-Identifier: CC0-1.0
subdir('cam_helper')
+subdir('common')
subdir('controller')
foreach pipeline : pipelines