summaryrefslogtreecommitdiff
path: root/src/ipa/rkisp1/meson.build
diff options
context:
space:
mode:
authorNiklas Söderlund <niklas.soderlund@ragnatech.se>2019-09-27 04:44:16 +0200
committerNiklas Söderlund <niklas.soderlund@ragnatech.se>2019-10-11 15:30:54 +0200
commitbf0915a4e808247fc26d817e66cc20e6d15067d3 (patch)
tree45271930b6001b0f10a43cc3f9f4bda2f69b6f4b /src/ipa/rkisp1/meson.build
parent97dce7a13fa373b5153335f8e47bdfac54014ad8 (diff)
libcamera: ipa: rkisp1: Add basic control of auto exposure
Add an IPA which controls the exposure time and analog gain for a sensor connected to the rkisp1 pipeline. The IPA supports turning AE on and off and informing the camera of the status of the AE control loop. Signed-off-by: Niklas Söderlund <niklas.soderlund@ragnatech.se> Reviewed-by: Jacopo Mondi <jacopo@jmondi.org> Reviewed-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com>
Diffstat (limited to 'src/ipa/rkisp1/meson.build')
-rw-r--r--src/ipa/rkisp1/meson.build7
1 files changed, 7 insertions, 0 deletions
diff --git a/src/ipa/rkisp1/meson.build b/src/ipa/rkisp1/meson.build
new file mode 100644
index 00000000..1cab319c
--- /dev/null
+++ b/src/ipa/rkisp1/meson.build
@@ -0,0 +1,7 @@
+rkisp1_ipa = shared_module('ipa_rkisp1',
+ 'rkisp1.cpp',
+ name_prefix : '',
+ include_directories : ipa_includes,
+ dependencies : libcamera_dep,
+ install : true,
+ install_dir : ipa_install_dir)