summaryrefslogtreecommitdiff
path: root/src/ipa/rkisp1/meson.build
diff options
context:
space:
mode:
authorJean-Michel Hautbois <jeanmichel.hautbois@ideasonboard.com>2021-11-18 14:43:24 +0100
committerJean-Michel Hautbois <jeanmichel.hautbois@ideasonboard.com>2021-11-29 20:41:37 +0100
commitb6fa52fc5bdc928daee0fd2fc33208bfdf0477d1 (patch)
tree15334fee65f4b87e2cc676f6cc63d79111b34dcc /src/ipa/rkisp1/meson.build
parentc2da6aab2154731c539eb645e02df4505843010d (diff)
ipa: rkisp1: Introduce IPAContext
Before using any algorithm, we want the IPAContext to be ready for those. Introduce the IPAContext following the existing design from IPA::IPU3. Each algorithm will then introduce the needed fields. Signed-off-by: Jean-Michel Hautbois <jeanmichel.hautbois@ideasonboard.com> Reviewed-by: Kieran Bingham <kieran.bingham@ideasonboard.com> Reviewed-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com>
Diffstat (limited to 'src/ipa/rkisp1/meson.build')
-rw-r--r--src/ipa/rkisp1/meson.build7
1 files changed, 6 insertions, 1 deletions
diff --git a/src/ipa/rkisp1/meson.build b/src/ipa/rkisp1/meson.build
index f76b37f5..3683c922 100644
--- a/src/ipa/rkisp1/meson.build
+++ b/src/ipa/rkisp1/meson.build
@@ -2,8 +2,13 @@
ipa_name = 'ipa_rkisp1'
+rkisp1_ipa_sources = files([
+ 'ipa_context.cpp',
+ 'rkisp1.cpp',
+])
+
mod = shared_module(ipa_name,
- ['rkisp1.cpp', libcamera_generated_ipa_headers],
+ [rkisp1_ipa_sources, libcamera_generated_ipa_headers],
name_prefix : '',
include_directories : [ipa_includes, libipa_includes],
dependencies : libcamera_private,