summaryrefslogtreecommitdiff
path: root/src/ipa/rkisp1/algorithms/meson.build
diff options
context:
space:
mode:
authorStefan Klug <stefan.klug@ideasonboard.com>2024-05-16 08:22:20 +0200
committerStefan Klug <stefan.klug@ideasonboard.com>2024-06-11 15:11:11 +0200
commiteb41f636941e13a92ddce7893d25abd747e23c45 (patch)
tree9059043854f3255696714733cd51508680ad557c /src/ipa/rkisp1/algorithms/meson.build
parentacfd602767638aa6ce19fd831d5221bdf233195c (diff)
ipa: rkisp1: Add GammaOutCorrection algorithm
Add a gamma algorithm for the rkisp1. It defaults to a gamma of 2.2 which closely resembles sRGB. No seperate sRGB mode was implemented because the pwl that models the gamma curve is so coarse that there is basically no difference between srgb and gamma=2.2. The default can be overridden within the tuning file or set at runtime using the gamma control. The gamma algorithm is not enabled by default. This will be done in future tuning file updates. Signed-off-by: Stefan Klug <stefan.klug@ideasonboard.com> Reviewed-by: Kieran Bingham <kieran.bingham@ideasonboard.com> Reviewed-by: Paul Elder <paul.elder@ideasonboard.com>
Diffstat (limited to 'src/ipa/rkisp1/algorithms/meson.build')
-rw-r--r--src/ipa/rkisp1/algorithms/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/ipa/rkisp1/algorithms/meson.build b/src/ipa/rkisp1/algorithms/meson.build
index 93a48329..6ee71a9b 100644
--- a/src/ipa/rkisp1/algorithms/meson.build
+++ b/src/ipa/rkisp1/algorithms/meson.build
@@ -8,6 +8,7 @@ rkisp1_ipa_algorithms = files([
'dpcc.cpp',
'dpf.cpp',
'filter.cpp',
+ 'goc.cpp',
'gsl.cpp',
'lsc.cpp',
])