summaryrefslogtreecommitdiff
path: root/src/ipa/rkisp1/algorithms/meson.build
diff options
context:
space:
mode:
authorFlorian Sylvestre <fsylvestre@baylibre.com>2022-07-27 10:40:49 +0200
committerLaurent Pinchart <laurent.pinchart@ideasonboard.com>2022-07-28 14:54:50 +0300
commita9bffb72221b43e49cdb60f0f6d663d973056011 (patch)
tree76d3b224b635ddc6b1361e37cfcbc6ab0d15dfe9 /src/ipa/rkisp1/algorithms/meson.build
parent03b555a901cd5bcca007e3fc8b9170b5e19420a4 (diff)
ipa: rkisp1: Add support of Gamma Sensor Linearization control
The GammaSensorLinearization algorithm linearizes the sensor output to compensate the sensor non-linearities by applying piecewise linear functions to the red, green and blue channels. Signed-off-by: Florian Sylvestre <fsylvestre@baylibre.com> Reviewed-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> Reviewed-by: Paul Elder <paul.elder@ideasonboard.com> Signed-off-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com>
Diffstat (limited to 'src/ipa/rkisp1/algorithms/meson.build')
-rw-r--r--src/ipa/rkisp1/algorithms/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/ipa/rkisp1/algorithms/meson.build b/src/ipa/rkisp1/algorithms/meson.build
index 7ec53d89..0597c353 100644
--- a/src/ipa/rkisp1/algorithms/meson.build
+++ b/src/ipa/rkisp1/algorithms/meson.build
@@ -4,4 +4,5 @@ rkisp1_ipa_algorithms = files([
'agc.cpp',
'awb.cpp',
'blc.cpp',
+ 'gsl.cpp',
])