summaryrefslogtreecommitdiff
path: root/src/ipa/raspberrypi/meson.build
diff options
context:
space:
mode:
authorNaushir Patuck <naush@raspberrypi.com>2020-11-26 10:49:49 +0000
committerLaurent Pinchart <laurent.pinchart@ideasonboard.com>2022-03-23 01:50:14 +0200
commitf687116904001cf9189bdf878d7c1e60b209c26a (patch)
treea54b24a1cd139ce4c8b4fb92c6a7fd913b08f2eb /src/ipa/raspberrypi/meson.build
parent3dc81300c73be0e406ce702811ba2b5dc5b516e2 (diff)
ipa: raspberrypi: Add camera helper for Sony IMX296 sensor
The Sony IMX296 sensor has an exponential gain model, and adds a fixed 14.26µs offset to the exposure time expressed in line units. Signed-off-by: Naushir Patuck <naush@raspberrypi.com> Signed-off-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> Reviewed-by: Naushir Patuck <naush@raspberrypi.com> Reviewed-by: Kieran Bingham <kieran.bingham@ideasonboard.com>
Diffstat (limited to 'src/ipa/raspberrypi/meson.build')
-rw-r--r--src/ipa/raspberrypi/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/ipa/raspberrypi/meson.build b/src/ipa/raspberrypi/meson.build
index 176055f4..32897e07 100644
--- a/src/ipa/raspberrypi/meson.build
+++ b/src/ipa/raspberrypi/meson.build
@@ -21,6 +21,7 @@ rpi_ipa_sources = files([
'cam_helper_ov5647.cpp',
'cam_helper_imx219.cpp',
'cam_helper_imx290.cpp',
+ 'cam_helper_imx296.cpp',
'cam_helper_imx477.cpp',
'cam_helper_imx519.cpp',
'cam_helper_ov9281.cpp',