summaryrefslogtreecommitdiff
path: root/src/ipa/raspberrypi/meson.build
diff options
context:
space:
mode:
authorNaushir Patuck <naush@raspberrypi.com>2021-07-12 11:02:04 +0100
committerLaurent Pinchart <laurent.pinchart@ideasonboard.com>2021-07-12 15:57:05 +0300
commitf24d83720f0ecd5656699f5013d7b5532e6e72c2 (patch)
tree74c3be8fc9897efe6c03a0ee78575c7c40e1c721 /src/ipa/raspberrypi/meson.build
parentdf8cafaf8788eb27c25576ce94ca605f8a50527d (diff)
ipa: raspberrypi: Add an operator<< to struct DeviceStatus
Add an operator<< overload to log all fields in DeviceStatus, and remove the manual logging statements in the IPA and CamHelper. Signed-off-by: Naushir Patuck <naush@raspberrypi.com> Reviewed-by: David Plowman <david.plowman@raspberrypi.com> Reviewed-by: Jacopo Mondi <jacopo@jmondi.org> Reviewed-by: Kieran Bingham <kieran.bingham@ideasonboard.com> Reviewed-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> Signed-off-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com>
Diffstat (limited to 'src/ipa/raspberrypi/meson.build')
-rw-r--r--src/ipa/raspberrypi/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/ipa/raspberrypi/meson.build b/src/ipa/raspberrypi/meson.build
index c9855018..1af31e4a 100644
--- a/src/ipa/raspberrypi/meson.build
+++ b/src/ipa/raspberrypi/meson.build
@@ -40,6 +40,7 @@ rpi_ipa_sources = files([
'controller/rpi/contrast.cpp',
'controller/rpi/sdn.cpp',
'controller/pwl.cpp',
+ 'controller/device_status.cpp',
])
mod = shared_module(ipa_name,